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Abstract

This paper discusses three scenarios of Cornell University research teams collaboratively using ATLAS.ti on a shared 
computing environment. The first scenario involves a Project Administrator (PA) creating a master team HU and a  
team library on a shared folder. The two other scenarios discuss the pitfalls of not correctly managing team project 
files. We describe each scenario and offer step-by-step instructions and solutions. All three scenarios described in 
this paper have team/my libraries located on a shared folder and used same PD-same code stock strategy when 
merging HUs. We also discuss the particulars of our shared computing environment, our general and team-specific 
recommendations as to how each team should manage their files, and other use cases concerning ATLAS.ti that 
came to our Helpdesk.
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Introduction

Interdisciplinary  research has  become increasingly  important  and prominent in  discoveries  and new 

technologies, and in finding solutions to complex problems (Van Hartesveldt and Girodan, 2008:9). Or

ganizations such as the U.S. National Science Foundation (NSF) have recognized that interdisciplinary 

research is critically important going forward. In their Strategic Plan for FY 2006-2011, they noted that 

“[d]iscovery increasingly requires the expertise of individuals with different perspectives – from different 

disciplines— working together to accommodate the extraordinary complexity of today’s science and en

gineering challenges.” (NSF, 2006:2).  

ATLAS.ti is one of the mechanisms through which interdisciplinary collaborations can be conducted, es

pecially projects that involve massive amounts of qualitative data. With its multi-authoring capabilities, 

ATLAS.ti is a great tool for collaborative processing and analysis of qualitative data.  It has flexible code 

and stock strategies, which can adapt to various configurations and analytical approaches of project 

teams.   

ATLAS.ti can also be installed in a server environment without any problems.    ATLAS.ti is being used 

successfully by thousands of research teams world-wide in a multitude of very heterogeneous deploy

ment/installation scenarios.  The fact that it works in a server environment encourages collaboration as 

some research team members who are geographically dispersed can just log in to the server via remote 

desktop protocol, Virtual Private Network (VPN), or thin client and process their primary documents us

ing ATLAS.ti.  It is also cost-effective as economies of scale makes ATLAS.ti’s multi-user educational li

cense affordable.  Furthermore, it provides users freedom to choose the work environment where they 
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can be most productive as they can log in to the server from anywhere in the world where they have in

ternet access e.g., from home, office, coffee shop, the field, or elsewhere.    

Since we believe in the capabilities and strengths of the software for collaborative research, we installed 

ATLAS.ti  on our  server,  a  private  cloud service  running on state-of-the-art  computing systems,  and 

placed safeguards to ensure it is being used within the bounds of our concurrent-user license agreement.  

This has the triple advantage of promoting ATLAS.ti, a tried and tested tool; the software can leverage 

the higher and more advanced computational resources of the server; and Cornell researchers have the 

option to access and process their data using ATLAS.ti from anywhere in the world where they have in

ternet access even without a physical instance of ATLAS.ti on their local computers. 

In this paper we present in detail how our researchers do collaborative work using ATLAS.ti installed on 

our private cloud environment. Specifically, we discuss the following:

• Our system environment, usage policy, and license usage tracking software;
• The default library settings of ATLAS.ti and confidentiality and privacy disclosure risks associated 

with its installation on the server;
• The warnings, trainings, and support we provide our users to avoid disclosure risks and make 

their experience in using ATLAS.ti installed on a server as seamless and painless as possible;
• The three different case scenarios based on real-life experiences of project teams, the problems 

encountered, and how they were addressed; and
• Other use case scenarios including the version 6 approach.

Our System Environment, Usage Policy, And License Compliance And Tracking Software

ATLAS.ti 7 is currently installed on a Dell R810, 40-core, 512 GB RAM MS windows Server 2008 R2 

Datacenter Edition x64. Our ATLAS.ti license is Educational Multiuser License 15 Units Lease.   We use 

Sassafras Key Server to track usage and enforce license compliance.  A user account is needed to gain ac

cess  to  our  server  and only  Cornell  researchers  and their  affiliates  are  given accounts.  Each user  is 

provided a space for file storage–the U drive. Currently there is no set quota for disk storage. Users (usu

ally the Project Administrator) can apply for a shared folder on the S drive where they can store their  

PDs, HUs, and Team Library. Each member of the team will have access to the shared folder, although  

their level of access could vary depending on the Project Administrator. Only members of the team have 

access to the shared folder and its contents. Non-team members are denied access.  This means our re

searchers can process their data using ATLAS.ti while off-campus or on fieldwork. They do not have to 

be housed in computer labs on campus.

Every second Thursday of the month we have our monthly downtime for maintenance and installation of 

patches and updates.   In the world of virtualization, CISER chooses to replace the operating system im

age with all current application updates applied and pre-tested. This allows us to meet university policy  

and shorten our systems outage during monthly downtime.   During downtime all user-installed contents  

on the C drive are deleted.   Like most software, ATLAS.ti follows commonly accepted MS Windows 

standards and writes its data only to those segments of the Windows operating system that are specific
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ally designated for the storage of user data/user settings.   It defaults the location of both My Library  

and Team Library on the C drive, and therefore their contents get deleted during our downtime.  So we 

remind our users not to store anything on the C drive and to redirect the path of the My Library to their  

personal user space (the U drive), and the Team Library to their team’s shared folder on the S drive.   

Importance Of Redirecting ATLAS.ti Default Library Settings To User Or Team Folders

ATLAS.ti’s  default  My  Library  location,  which  follows  Windows  symbolic  paths,  is 

C:\Users\<username>\AppData\Roaming\Scientific  Software\Atlasti\Repository\Managed  Files.    The 

library is a hidden folder, meaning it cannot be found unless the user changes the folder settings, and its  

file contents are encrypted by ATLAS.ti.  Being user-specific, only the user can view, access, and use the 

PDs on this library. In Figure 1 and Figure 2, the contents of the My Library folder are only viewable to 

user foa2_TS and yp269_ts, respectively.

The  default  Team  Library  location  on  the  other  hand  is  C:\Users\Public\Documents\Scientific  

Software\Atlasti\Repository\Managed Files (see  Figure 1 and  Figure 2). This folder is also hidden by 

default and its files encrypted.  However, being public, all users who open an ATLAS.ti HU can view, 

access, and use the PDs on this library, even if they are not members of the project team. 

Figure 3 shows what happens when users add primary documents to the default Team Library location. 

The two files on the list do not belong to users foa2_TS nor yp269_ts, yet they can access, view, and use 

these primary documents. 

Depending on the type of document being processed, this could potentially breach privacy and confiden

tiality promised by researchers to interviewees, especially if the primary documents were not subjected to 

disclosure-avoidance techniques.  If another team uses this default setting, they too will be adding their  

documents to this public library.  And if another team decides to redirect this library to their own team’s  

shared folder, all the other teams’ primary documents residing in the public library will also be moved to 

that new location.

The work of new teams can also be delayed by teams whose files reside on the public domain.  New pro

ject teams will not be able to redirect the default team library to their shared folder until the team who 

owns the files on the public domain have redirected the library to their own shared folder.
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Since there is a possibility of loss of files and/or accidental disclosure especially among novice users of 

our system, we took the following steps to prevent or mitigate its re-occurrence:

 Since each project team has their own approach of analyzing their qualitative data, we provided 
free customized training for teams on how to manage their files using ATLAS.ti on our servers 
emphasizing not to touch the contents of the libraries, not to move the source documents from 
their original location so it can still be retrieved in case a file in the library cannot be found, and to 
redirect their team library to its designated location on their shared folder. 

 In addition to the training, once a week we also monitor the public Team Library for shared docu
ments and inform the unaware users that they have PDs posted on the public domain. We could 
delete them from the library, too, if necessary, because ATLAS.ti alerts the user if it cannot find a 
PD in the library and can retrieve it from the original source location provided it has not been 
modified (see Figure 3). However, we give users the opportunity to act on the PDs themselves. 
We advise them to redirect the path of their Team library to its location on their shared folder be
fore adding back the document.
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 We also inserted a warning (see  Figure 4) in bold red that pops-up every time users start their 
ATLAS.ti sessions to remind them to redirect or make sure their Team library is pointing to the cor
rect library and not on the C drive especially since our downtime resets the ATLAS.ti libraries’  
location back to their default location on the C drive. The complete instructions are found here: 
http://ciser.cornell.edu/FAQ/  ATLAS.ti  /redirectLibs.shtm  

 We also remind our users to copy bundle their files for backup purposes, and still store the bundle 
on their shared folder as all the contents of the shared folder are automatically backed up nightly.  
Copy bundling of files for distribution to team members to be worked on is not necessary in our 
private cloud environment as everyone has access to their shared folder.  This minimizes the pro
liferation of copies and enhances the security of qualitative data in this digital age (Aldrige, et. Al,  
2010).

 On top of the trainings, warnings, and monitoring of public libraries, we also have a consulting 
helpdesk that ATLAS.ti users can contact for tech support. The CISER Helpdesk is open 2-6 hours 
a day, 6 days a week and can be contacted via e-mail, phone, walk-in, and live chat.
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Server-based Team Work

Given the backdrop of our computing environment and ATLAS.ti’s new library features, we present in 

detail the steps, observations, and results of collaborative work using ATLAS.ti on our server. This is fol

lowed by a description of two scenarios that present commonly made mistakes.

EDITORS' COMMENT: This paper and reports of other users in a similar context have given rise at the ATLAS.ti  
headquarters to re-think the work-flow for team projects. By May/June 2014, an additional option to create a team  
library for each team project will become available. Even though this will render the following description obsolete,  
without it the change in the software wouldn't have occurred. Therefore, a special thanks go to the authors for  
firstly finding a work-around that fitted their situation, and secondly for spending time and effort to attend the con
ference and for writing the paper. 

The most common set up for project teams is that of a Project Administrator (PA) creating a master team 

HU and a team library on a shared folder. Each member creates, processes, and analyzes a copy of the  

HU that has its team library location set to the one created by the PA. The PA later combines all the team 

HUs.   In a shared folder, all members have access to the files and copy bundling files to distribute to  

members is no longer necessary as members can directly create a copy of the master HU themselves and 

work on their copy.
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Role Of PA

1. PA connects to their server account, stores the original PDs on their team’s shared folder on the 
server, invokes ATLAS.ti, creates a Team HU (Documents>New>This is a Team HU>Enable Team 
Mode), and saves the HU (giving it a name, say Case1_Master) on the shared folder.

EDITORS' COMMENT: Clicking on the menu option “This is a Team HU” is only necessary if you want to drag &  
drop documents onto the HU Editor. In Team mode, ATLAS.ti automatically selects the team library as default loca
tion. When adding Documents via the main menu, then you can skip this step.

2. PA  moves  the  default  team  library  location  to  the  location  of  the  shared  folder 
(Documents>Data Source Management>Open Library Manager>Extras>Manage Library Loca
tion, click on the folder icon next to Team Library, then browse to the shared folder location, 
then hit OK twice). A Managed Files subfolder is automatically created by ATLAS.ti within the 
shared folder.

3. PA adds primary documents to the Team Library (Documents>New>Add Documents (Team Lib
rary), selects the PDs, and hits Open).

4. PA saves the HU and informs the team of its availability, for each member to make a copy of it, 
where to store it on their shard folder, and which path they should redirect the team library.

5. PA also instructs not to touch the folder called “Managed Files” found on their shared folder be
cause it contains encrypted versions of their PDs which are the ones used by ATLAS.ti.  The soft 
ware actually warns users when they open the Managed Files folder with a text file named 
“do_not_touch_this_folder.txt,” which contains the following message: “This directory contains 
the documents used in one of your HU project.  The files inside this directory shall not be de
leted, renamed or modified in order to ensure the sanity of your HU.”

 Role Of Team Members (including PA)

• Each Team Member (TM, henceforth) connects to their server account, invokes ATLAS.ti on the 
server, opens the master HU and creates a copy of it by saving the HU and affixing their name 
or initials to its original name (Project>Save As>new-name-of-HU).  They save the HU on the 
shared folder, either in the same location as the master HU, or on a sub-folder within the shared  
folder created by the PA for the purpose of storing and organizing members’ HU’s.

• Each TM logs in (Tools>User Management>Switch User…) or creates a login (Tools>User Man
agement>User Editor>Edit>New User>Account Name>Password>Last Name>First Name>Ok), 
so that every object created by the TM gets tracked.

Note 1:  The HERMENCR.HDB file which stores the user database, gets modified in the process of creat

ing new user accounts in ATLAS.ti.  In addition, the ATLAS.INI file, which contains instructions on wheth

er to enable or disable login password, may be modified as well. During our monthly downtime both 

HERMENCR.HDB and ATLAS.INI are refreshed backed to their default settings. This means that all user 

names created and stored on the HERMENCR.HDB file and any changes made to the ATLAS.INI file  

between downtimes are lost. To address this, we simply instruct our users to recreate their login name in 

case they do not see their name on the login dropdown-list, and not to make changes to the Atlas.ini 

file.

Note 2: Login names created by users can be edited, deleted, or used by all users of ATLAS.ti on our  

server, but does not pose any risk to outsiders (other teams) because users can only open the files that 

are  on their  shared folder.  It  could cause trouble for the team if  a team member tries to log in as  

someone else to deliberately sabotage the team or another member.  This can be avoided by the project 
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administrator setting up user accounts and creating co-authors adding them to the project and providing 

only standard rights to co-authors. A user with standard rights cannot change user accounts.

• Each TM sets the location of their HU’s Team Library to the team library created by the PA 
(Documents>Data  Source  Management>Open Library  Manager>Extras>Set  Library  Location, 
then navigate to the Team library on the shared folder, then hit OK twice).

Note:  Each TM follows the instructions of the PA to redirect the location of the Team HU when they 

open ATLAS.ti for the first time because, by default, the Team Library points to the public location on the 

C drive. If they fail to redirect the library, they will be alerted by a message that says “A library entry re

ferred to by a primary document is missing” and will ask if the user wants to use the matching file found  

in the HU’s folder instead.

• Each TM does its own processing and analysis and saves the HU on the designated HU storage 
location.  They do not have to copy bundle their HU and send to the PA for merging as the PA 
has direct access to their HUs (and so do the rest of the members).  They can use copy bundle 
though for backing up their work.

• The PA combines the HU one at a time (Project>Merge with HU) using same PD-same code 
stock  strategy,  and  saves  the  combined  HU and  versions  it  by  giving  it  a  new name,  say  
Case1_Master2.   If more work is to be done by the members on this merged HU, they simply 
follow the same process as they did in the first pass. Several iterations may pass before the pro
ject objectives are satisfied. Generally, hardly any problems are encountered when using this col
laborative approach.  

Common Mistake 1 - Documents Are Accidentally Added To My Library Instead Of The Team Library.

Each member then creates, processes, and analyzes a copy of the HU created by the PA and point their 

HU’s My Library location to the one created by the PA.   The PA later combines all HUs.

EDITORS' COMMENT: If the PA recognizes that he or she used the wrong library to set up the project, all docu
ments can be moved from My Library to the Team Library: Select all documents in the primary document manager,  
right click and select the option Data Source Management / Copy Selected Documents to Team Library. Then the in
structions of CASE 1 apply.

If you continue to use My Library even if you work in a team – technically this makes no difference and it  

is OK to do – you have to proceed as follows:

Role Of PA

• PA connects to their server account, and stores the source documents on their team’s 
shared folder on the server.  

• PA  invokes  ATLAS.ti,  adds  primary  documents  to  the  My  Library location 
(Documents>New>Add Documents (My Library), selects the PDs, and hits Open ), and 
saves the HU on the shared folder and giving it a name, say Case2_Master.  Note:  This 
stores the encrypted PDs to the default My Library location on the C drive.

• PA moves the default My Library location to the location of the shared folder (Docu
ments>Data  Source  Management>Open  Library  Manager>Extras>Manage  Library  
Location, click on the folder icon next to My Library, then browse to the shared folder 
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location, then hit OK twice). A Managed Files subfolder is automatically created by AT
LAS.ti within the shared folder.

• PA saves the HU and informs the team of its availability, and where to redirect the My 
Library path.

Role of TM (including PA)

Same as in Case 1 except that they set the location of their My Library to the location set by the PA on 

their shared folder.  Results of merging using the same PD-same code stock strategy are the same as in  

Case 1.

Common Mistake 2 - Each Member Creates Their Own Team HU Individually

EDITOR COMMENT: This should be avoided. If you work in a team, pick one person who takes on the role of pro
ject administrator and this person sets up and monitors the project. The only exception is if all team members start  
out with a different set of documents. Only then can they set up their own projects and later send it to the PA.

The situation at Cornell university started with the PA, who created a Team HU on his own and sets up  

the Team library containing the project PDs. Each member then created their own Team HU, pointed the  

Team library of their HUs to that set by the PA, and added PDs to their HUs from the team library. The 

PA later combined the HUs, but instead of merging the PDs, the PDs were added.

EDITORS' COMMENT: This also occurs when each team member adds the same documents from different loca
tions, e.g. if they do not have access to a shared folder. Why is that so?

This is because each primary document has a unique fingerprint that is generated during its inclusion to 

the HU. The fingerprint of a PD has to be identical on all HUs for it to be successfully merged.  Refer to  

pages 162-164 of the ATLAS.ti Users Manual   (http://manual.atlasti.com)

EDITORS'  COMMENT: One could ask why primary documents also receive unique fingerprints when added from  
the library. The reason for this is that the HU / ATLAS.ti cannot know what your intention is. You might want to add  
the same data source file more than once to a project because you want to analyze it from different angles. Thus,  
ATLAS.ti does allow you to add the same file two or even more time unless you deactivate the option “Allow more  
than one PD per data source.” Under Tools / Preferences / General Preferences  HU Editor. 
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When merging projects that contain PDs referring to the same data source, but that have been added to  

different HUs, the same applies. The HU does not know your intention; therefore PDs referring to the 

same data source files are added rather than merged in the first step. The PA can then say: No, this is not  

what we wanted; our intention is different and merge those PDs manually afterwards. This is how it 

works:  Select Documents>Primary Doc Manager>select the two identical files through ctrl-click> then 

click Miscellaneous>Merge Selected PDs>Unify>OK.

To avoid this situation from happening, the PA should setup the Master HU with PDs for the project and 

distribute copies of the HU to the TMs (which could be personalized to reflect the TM’s name) or the 

TMs make copies of the Master HU. This ensures all fingerprints of the PDs are consistent in all HUs and 

therefore can be successfully merged.  An alternative would be to provide copy bundle files to each  

member, but this is not necessary in a shared working environment.
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Other Use Cases

New Project, New Dataset, Same Team, Same Server Account

It is common for some of our users to be involved in multiple researcher projects and some are caught in  

a situation where they have to manage a new project with new sets of data to be stored on a new 

shared folder.

The primary dilemma in this situation is that when the user opens ATLAS.ti, its Team library is still point

ing to its previous project’s Team library on the shared folder. If the library is moved or a new one is cre 

ated via Manage Library Locations, all the primary documents of the previous project will be moved to 

the current project’s Team Library. 

Three solutions are offered, and the third is a request/appeal/suggestion to ATLAS.ti developers.

Solution 1

The PA resets the location of the Team library to the default Public. (Documents > Data Source Manage

ment > Open Library Manager > Extras > Set Library Location, then click the Reset button next to Team 

library, then hit OK).  When the location of the Team library is reset to the default Public, the location of  

Team library under Manage Library location also changes to Public. Set Location will not move the Team 

library, but will only point the library to a different location– in this case back to the (hopefully) empty  

Public library on the C drive. The PA then adds the document to the team library at the default location  

and redirects it afterwards to the new shared folder.

Solution 2

New user accounts and shared folder for team members of the new project are created on our server.  

Solution 3

To simplify solution 1, we propose to the ATLAS.ti developers a third option to be placed under Docu

ments > Data Source Management > Extras > “Create New Library Location,” that creates a new Library 

for a new project while not moving the files of the previous project’s library to the new project’s library.

EDITORS' COMMENT: There is a good reason why this is not possible. The managed library feature was added to  
version 7 because in version 6 users were prone to loose access to their documents. If an option to create new lib
rary locations were to be added, there is a good chance that users would create a library for each new project and  
lose track of where their documents are stored for each project. Such a solution would require setting the library  
location for each project to the correct library location—and end up with the same situation from version 6 where  
the most frequently asked question used to be: “Help! Where are my documents?”. 

12



HOW TO COLLABORATE AS A TEAM USING ATLAS.TI WITHIN A SHARED COMPUTING ENVIRONMENT

Using Version 6 Approach To Collaborative Work

Some teams use the version 6 approach for managing files, which is not lost in ATLAS.ti 7. ATLAS.ti 7 

continues to provide users the option to manage the data themselves using the Assign External Docu

ment  option  (Documents>New>Assign External  Documents).   There  are  two restrictions  to  this  ap

proach: Linked documents cannot be edited. Editing linked documents in teams is problematic anyway as 

you make changes to the data source. If the linked source files are NOT stored in a shared folder and 

two or more team members edit the source file, you end up with different versions of the file and mis

aligned codings. In order to prevent such a situation, editing is prohibited. If you attempt to edit a linked  

file, the following message pops up:

The  second  restriction  is  that  you 

cannot  work  with  associated  docu

ments (A-Docs) as by default the as

sociated  media  sources  need  to  be 

added to either of the two libraries. 

This, however, might change in the 

future, as we have been informed by 

the ATLAS.ti team.

Conclusion

A highly collaborative environment and qualitative research methodology requires a QDA software pack

age that is flexible and promotes collaborative work among researchers dispersed in various areas of the 

globe.  ATLAS.ti is a very powerful tool for collaborative work in the analysis of qualitative data.  The fact 

that it can be installed in a server environment without any problems makes it all the more endearing to 

research teams as members can be geographically dispersed and still be able to access their HUs from 

any location in the world where they have internet access.   This also allows more freedom to choose a 

more productive working environment for team members to process their data.  Further, it is cost-effect

ive as economies of scale makes ATLAS.ti’s multi-user educational license affordable.  

In this paper we showed how we made ATLAS.ti work in our private cloud environment to promote col

laboration among Cornell Researchers doing qualitative data analysis.  Installation of the software on the 

server is easy, but its successful use and implementation requires a tracking software to track usage and 

enforce license compliance; that teams be made aware about ATLAS.ti’s library management features 

and how it interacts with our usage, the fingerprints it places on primary documents, and figuring out the 

best setup for collaboration depending on the analytical approach adopted by the project team.   This  

awareness can be done with customized trainings for project teams that address their unique setup and 
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needs combined with reminders to redirect libraries to their appropriate location, and readily available  

on-campus tech support that project teams can rely upon for immediate help.

The case scenarios we discussed indicate that having a shared folder for project teams to store their files  

and library matters and is more efficient.  Copy bundling then installing the bundle for consolidation is no 

longer necessary as files are centrally located and Project Administrators have direct access to the mem

bers HU (and so do other members).   Proliferation of copies of the data is also mitigated as all work is 

done and stored on the server.   
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